欢迎访问悦橙教程(wld5.com),关注java教程。悦橙教程  java问答|  每日更新
页面导航 : > > > 文章正文

subString,

来源: javaer 分享于  点击 37738 次 点评:32

subString,


描述 Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 


我是利用暴力的解法但是奇怪的是竟然AC过了




填上我的代码如下


#include<iostream>
#include<string>
using namespace std;
int times(char*str,char* substring)
{
    int time = 0;
   while(*str)
   {
              char *copstring = substring;
              while(*copstring)
              {
                               if(*copstring!=*str)
                               {
                                         break;         
                                          }
                               copstring++;
                               str++;
              }
              if(!*copstring)
              {
                             ++time;
                            
                            
                             }
                             str = str - (copstring-substring)+1;
                             copstring = substring;
                             }
                             return time;
              
}
int main()
{
    int Times;
    cin>>Times;
    while(Times--)
    {
                  char str[1000];
                  char substr[10];
                 
                  cin>>substr;
                  
                   cin>>str;
                  cout<<times(str,substr)<<endl;
                  }
    return 0;
}



相关文章

    暂无相关文章

用户点评