NYOJ-308-Substring(第四届河南省程序设计大赛F题(简单状压dp)),
分享于 点击 30979 次 点评:71
NYOJ-308-Substring(第四届河南省程序设计大赛F题(简单状压dp)),
Substring
时间限制:1000 ms | 内存限制:65535 KB 难度:1- 描述
-
You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input.
Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.
- 输入
- The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').
- 输出
- Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input
- 样例输入
-
3 ABCABA XYZ XCVCX
- 样例输出
-
ABA X XCVCX
题解:
题目大意:注意,这道题不是最长回文字符串。而是从原串中找一个子串,反转后使其与原串匹配最大长度的字串。
题解 :只需将原串整个反转一下求最长公共字串。简单的dp。
下面附上代码:
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int main()
{
int n, i, j, k, s, a[2][55], len, maxx;
char ch[55];
scanf("%d\n", &n);
while(n--)
{
gets(ch);
memset(a, 0, sizeof(a));
len=strlen(ch);
for(i=len-1, maxx=0; i >= 0; i--)
for(j=0, k=i%2; j < len; j++)
if(ch[i] == ch[j])
{
a[k][j+1]=a[!k][j]+1;//状态压缩
if(a[k][j+1]>=maxx)
{
maxx=a[k][j+1];
s=i;
}
}
else a[k][j+1]=0;
for(i=0; i<maxx; i++)
printf("%c",ch[i+s]);
cout<<endl;
}
}
相关文章
- 暂无相关文章
用户点评