欢迎访问悦橙教程(wld5.com),关注java教程。悦橙教程  java问答|  每日更新
页面导航 : > > > 文章正文

第四节河南省程序设计大赛-NYOJ-308-Substring,

来源: javaer 分享于  点击 47189 次 点评:116

第四节河南省程序设计大赛-NYOJ-308-Substring,


Substring
时间限制:1000 ms | 内存限制:65535 KB
难度:1
描述
You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input.

Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.

输入
The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter (‘A’-‘Z’).
输出
Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input
样例输入
3
ABCABA
XYZ
XCVCX
样例输出
ABA
X
XCVCX

题意:给出字符串,然后输出字符串和其翻转后的字符串的最长公共子序列。
注意不是求回文串!

string用法http://blog.csdn.net/qq_32680617/article/details/51122395

#include<stdio.h>
#include<string.h>
#include<string>
#include<algorithm>
#include<iostream>
#include<math.h>
using namespace std;
int main()
{
    int N;
    scanf("%d",&N);
    while(N--)
    {
        string s1,s2,s3;
        cin>>s1;
        s2=s1;
        reverse(s2.begin(),s2.end());
        int max_num=0;
        int len=s1.size();
        for(int i=0; i<len; i++)
        {
            for(int j=1; j<=len-i; j++)
            {
                string::size_type pos=s2.find(s1.substr(i,j));
                if(pos!=string::npos&&max_num<j)
                {
                    max_num=j;
                    s3=s1.substr(i,j);
                }
            }
        }
        cout<<s3<<endl;
    }
    return 0;
}

从这题开始系统的接触string,map,list等STL标准模板库

相关文章

    暂无相关文章

用户点评