欢迎访问悦橙教程(wld5.com),关注java教程。悦橙教程  java问答|  每日更新
页面导航 : > > > 文章正文

Substring,

来源: javaer 分享于  点击 23036 次 点评:2

Substring,


Substring

时间限制:1000 ms  |  内存限制:65535 KB 难度:1
描述

You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input. 

Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.

输入
The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').
输出
Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input
样例输入
3                   
ABCABA
XYZ
XCVCX
样例输出
ABA
X
XCVCX
分析:使用string字符串处理http://blog.csdn.net/zchlww/article/details/45361743
代码一:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	int ncase, i, j, maxlen;
	scanf("%d", &ncase);
	while(ncase--)
	{
		string str, tmp, res; //str原始数据,tmp倒置str,res相同子串
		cin>>str;
		tmp = str;
		reverse(tmp.begin(), tmp.end()); //倒置
		maxlen = 0;
		for(i = 0; i < str.size(); i++)
		{
			for(j = 1; j <= str.size() - i; j++) //j代表截取的长度
			{
				if(tmp.find(str.substr(i, j)) != string::npos) //如果截取匹配
				{
					if(j > maxlen)
					{
						maxlen = j; //长度更新
						res = str.substr(i, j); //最长子串
					}
				}
			}
		}
		cout<<res<<endl;
	}
	return 0;
}
代码二:
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main()
{
  string s1,s2;
  int n;
  cin>>n;
  while(n--)
  {
    cin>>s1;
    s2=s1;
    reverse(s2.begin(),s2.end());//反转字符串
    bool flag=false;
    for(int i=s1.size();i>0;i--)//可以从最长字符串遍历
    {
      for(int j=0;j<=s1.size()-i;j++)
      {
        string t=s1.substr(j,i);
        string::size_type pos=s2.find(t);
        if(pos!=string::npos)
        {
          cout<<t<<endl;
          flag=true;
          break;         
        }
      }
      if(flag)  break;
    }
 }
 return 0;
}

相关文章

    暂无相关文章

用户点评