欢迎访问悦橙教程(wld5.com),关注java教程。悦橙教程  java问答|  每日更新
页面导航 : > > > 文章正文

第四届省赛题 Substring,第四届substring

来源: javaer 分享于  点击 6004 次 点评:120

第四届省赛题 Substring,第四届substring


Substring

时间限制:1000 ms  |  内存限制:65535 KB 难度:1
描述

You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input. 

Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.

输入
The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').
输出
Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input
样例输入
3                   
ABCABA
XYZ
XCVCX
样例输出
ABA
X

XCVCX

题意:给你一个字符串,然后让你找他的反串与原串的最长公共子串!  不是求回文串的.....

#include<string.h>
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
char ch[55];
char hc[55];
char zc[55][55];
int main()
{
    int n;
    int len;
    int i,j;
    scanf("%d",&n);
    while(n--)
    {
        int max=0,k;
        memset(zc,0,sizeof(zc));
        scanf("%s",ch);
        len=strlen(ch);
        for(i=0;i<len;i++)
            hc[i]=ch[len-i-1];
        //for(i=0;i<len;i++)
          //  printf("%c",hc[i]);
        for(i=1;i<=len;i++)
            for(j=1;j<=len;j++)
            {
              if(hc[j-1]==ch[i-1])
              {
                  zc[i][j]=zc[i-1][j-1]+1;
                  if(max<zc[i][j])
                  {
                      max=zc[i][j];
                      k=i;
                  }
                 // printf("%d**\n",k);
              }

            }
           // printf("%d  %d***\n",max,k);
            for(i=k-max;i<k;i++)
                printf("%c",ch[i]);
            printf("\n");



    }
    return 0;
}


相关文章

    暂无相关文章

用户点评