欢迎访问悦橙教程(wld5.com),关注java教程。悦橙教程  java问答|  每日更新
页面导航 : > > > 文章正文

字符串——Ny 308 Substring,nysubstring

来源: javaer 分享于  点击 3195 次 点评:287

字符串——Ny 308 Substring,nysubstring


Substring

时间限制:1000 ms  |  内存限制:65535 KB 难度:1
描述

You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input. 

Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.

输入
The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').
输出
Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input
样例输入
3                   
ABCABA
XYZ
XCVCX
样例输出
ABA
X
XCVCX

#include<iostream>
#include<string>
#include<algorithm>

using namespace std;

int main(void)
{
	string str1, str2, longestSubstr;
	int ncases;
	cin>>ncases;
	while (ncases-- != 0)
	{
		cin>>str1;
		str2 = str1;
		reverse(str2.begin(), str2.end());

		int maxlen = 0;
		int len, i;
		//子串长度递减
		for (len = str1.length(); len > maxlen; len--)
		{
			//子串位置逐渐靠后
			for (i = 0; i + len <= str1.length(); i++)
			{
				if (str2.find(str1.substr(i, len)) != string::npos)
				{
					maxlen = len;
					longestSubstr = str1.substr(i, len);
					break;
				}
			}
		}
		cout<<longestSubstr<<endl;
	}
	return 0;
}

相关文章

    暂无相关文章

用户点评