nyoj308 Substring 河南第4届省赛,nyoj308substring
分享于 点击 47925 次 点评:184
nyoj308 Substring 河南第4届省赛,nyoj308substring
Substring
时间限制:1000 ms | 内存限制:65535 KB难度:1- 描述
You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input.
Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.
- 输入
- The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').
- 输出
- Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input
- 样例输入
3 ABCABA XYZ XCVCX
- 样例输出
ABA X XCVCX
- 来源
- 第四届河南省程序设计大赛
#include<stdio.h>
#include<string.h>
#include<string>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
int N;
scanf("%d",&N);
while(N--)
{
string s1,s2,s3;
cin>>s1;
s2=s1;
reverse(s2.begin(),s2.end());//倒置字符串s1
int maxnum=0;
int len=s1.size();
for(int i=0;i<len;i++)
{
for(int j=1;j<=len-i;j++)
{
string::size_type pos=s2.find(s1.substr(i,j));
//在s2中寻找到s1的一个子串
if(pos!=string::npos&&maxnum<j)
//返回一个名为 string::npos 的特殊值,说明查找没有匹配。string 类将 npos 定义为保证大于任何有效下标的值。
{
maxnum=j;
s3=s1.substr(i,j);//选出合适子串给s3
}
}
}
cout<<s3<<endl;
}
return 0;
}
相关文章
- 暂无相关文章
用户点评