nyoj308,
分享于 点击 18913 次 点评:191
nyoj308,
Substring
时间限制:1000 ms | 内存限制:65535 KB难度:1- 描述
You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input.
Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.
- 输入
- The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').
- 输出
- Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input
- 样例输入
3 ABCABA XYZ XCVCX
- 样例输出
ABA X XCVCX
- 来源
- 第四届河南省程序设计大赛
- 上传者
- 张云聪
string的函数的使用
代码如下:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<stack>
using namespace std;
int main(){
int n,len;
string s,s1;
scanf("%d",&n);
while(n--){
cin>>s;
len=s.length();
string ans;
for(int i=0;i<len;i++){
for(int j=1;j<=len;j++){
s1=s.substr(i,j);
string s2(s1.rbegin(),s1.rend());
if(ans.length()<s1.length()&&s.find(s1)!=string::npos&&s.find(s2)!=string::npos){
ans=s1;
}
}
}
cout<<ans<<endl;
}
}
相关文章
- 暂无相关文章
用户点评