欢迎访问悦橙教程(wld5.com),关注java教程。悦橙教程  java问答|  每日更新
页面导航 : > > > 文章正文

nyoj 308 Substring,nyoj308substring

来源: javaer 分享于  点击 38210 次 点评:206

nyoj 308 Substring,nyoj308substring


Substring

时间限制:1000 ms  |  内存限制:65535 KB 难度:1
描述

You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input. 

Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.

输入
The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').
输出
Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input
样例输入
3                   
ABCABA
XYZ
XCVCX
样例输出
ABA
X
XCVCX
#include<stdio.h> 
#include<string.h> 
int main() 
{ 
    int n,i,j,len,k,max; 
    char a[55],b[55],c[55][55]; 
    scanf("%d",&n); 
    while(n--) 
    { 
        max=0; 
        memset(c,0,sizeof(c)); 
        getchar(); 
        scanf("%s",a); 
        len=strlen(a); 
        for(i=0;i<len;i++) 
            b[i]=a[len-i-1]; 
        for(i=1;i<=len;i++) 
            for(j=1;j<=len;j++) 
                if(a[i-1]==b[j-1]) 
                { 
                    c[i][j]=c[i-1][j-1]+1; 
                    if(c[i][j]>max) 
                    { 
                        max=c[i][j]; 
                        k=i; 
                    } 
                } 
        for(i=k-max;i<k;i++) 
            printf("%c",a[i]); 
        printf("\n"); 
    } 
    return 0; 
}
 

相关文章

    暂无相关文章

用户点评