欢迎访问悦橙教程(wld5.com),关注java教程。悦橙教程  java问答|  每日更新
页面导航 : > > > 文章正文

Substring,

来源: javaer 分享于  点击 39923 次 点评:162

Substring,


Substring

时间限制:1000 ms  |  内存限制:65535 KB
描述

You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input. 

Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.

输入
The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').
输出
Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input
样例输入
3                   
ABCABA
XYZ
XCVCX
样例输出
ABA
X
XCVCX
来源
第四届河南省程序设计大赛
上传者

张云聪

思路:用二维的矩阵来做。。

#include<iostream>
#include<string.h>
using namespace std;
int main()
{
    int num[51][51];
    char a[51],b[51];
    int T,i,j,k,len,max,x,y,start;
    cin>>T;
    while(T--)
    {
              memset(num,0,sizeof(num));
              k=0;
              max=0;
              cin>>a; //ABCABA
              len=strlen(a);
              for(i=len-1;i>=0;i--)
              {
                   b[k++]=a[i];
              }
              b[k]='\0';
              for(i=1;i<=len;i++)
              {
                 for(j=1;j<=len;j++)
                 {
                   if(a[i-1]==b[j-1]) 
                   {
                      num[i][j]=num[i-1][j-1]+1;
                      if(num[i][j]>max)
                         {
                           max=num[i][j];//max最大的长度 
                           x=i;
                           y=j;
                         }
                   }
                 }
              }
            start=x-max;
            for(i=start;i<start+max;i++)
               cout<<a[i];
               cout<<endl;                       
    }
return 0;
}

相关文章

    暂无相关文章

用户点评